Mac version won't play soundtrack music

Report issues or bugs in RVGL or ask for help regarding any Re-Volt topic.
particlefeever
Posts: 2

Mac version won't play soundtrack music

Unread post by particlefeever » Sat Apr 30, 2022 8:06 pm

Hi! I have just joined Re-Volt Network!

I have installed the RVGL Mac version in my Macbook Pro mid 2012 with Big Sur and it's running perfectly, so far. But it won't play any music. I love the soundtrack of this game, so I have downloaded the soundtrack from the website and copied to redbook folder inside app folder. No luck :pout:

What is strange is the ogg files won't play by the system (when pressing play in the icon), I have to play it using Ampado. Maybe there is some codec missing so the app won't play too, or some rights to fix, I don't know...

Any ideas?
User avatar
Huki
Developer
Posts: 381

Re: Mac version won't play soundtrack music

Unread post by Huki » Mon May 02, 2022 1:18 am

Game content is not loaded directly from the app folder. They get copied to ~/Library/Application Support/RVGL on first run. This is where you should place additional content and soundtrack. See the docs section on macOS data path.

Alternatively, just get the full game package from re-volt.io. It already contains original soundtrack and game files, and they get copied to the right place, so there is no need to copy any files manually.
particlefeever
Posts: 2

Re: Mac version won't play soundtrack music

Unread post by particlefeever » Tue May 03, 2022 12:42 pm

Huki wrote: Mon May 02, 2022 1:18 am Game content is not loaded directly from the app folder. They get copied to ~/Library/Application Support/RVGL on first run. This is where you should place additional content and soundtrack. See the docs section on macOS data path.

Alternatively, just get the full game package from re-volt.io. It already contains original soundtrack and game files, and they get copied to the right place, so there is no need to copy any files manually.
Yeah! I just copied the files to the App Support folder and now it's playing! Thanks so much, I just love this soundtrack! :D

I also tried to make work the audio play thought Finder by clicking in icon's play button by installing ogg vorbis utilities, using home-brew. Wont't work. Apple appears to have something against ogg and FLAC. Apple sucks! Tom sucks!
Post Reply