Constant stuttering in multiplayer

Report issues or bugs in RVGL or ask for help regarding any Re-Volt topic.
User avatar
Balesz
Posts: 40
From: Behind you

Constant stuttering in multiplayer

Unread post by Balesz » Thu Oct 26, 2023 5:45 pm

Hello there!

I didn't find anything related to this topic in the search menu, so I'm making one.

PC specs:
Win10 Pro
Ryzen 5 2600
GTX 1070
16GB RAM 2666MHz

So my problem is that almost every race I play online my frame drops to 0 midrace. It started years ago, I have no idea when. They usually last less than a second, but sometimes it can take more, my personal best is on Toytanic 2 where I had 2 seconds of frozen screen and audio, ingame music and system sounds played just fine. After the stutter everything goes back to normal, except I'm still at the same position and speed as I was before the stutter, while people around me didn't stop on their client side, so they can be from a couple to tens of meters ahead of me. It's not rare that people overtook me while this happened. At this point I figured out that I can weaponize it using zaps and rockets, but it would be way better to just play the game normally (and maybe it's just a little bit unethical :hausderp:).
Also I can play hours in singleplayer and not a single stutter is happening.


Troubleshooting things i made:
Reinstalling RVGL: no luck

Messing with RVGL config: nope

Updating ALL drivers (even GPU bios, oh yes, I used to have a 1050ti and I had the same issue)

Capping FPS to 60-120-240-480 through Nvidia control panel: it runs 1000+ unlimited

Closing Discord and/or all unncecessary apps: this fixed it for some people, I'm still stuttering, lucky me

Running Android RVGL through Bluestacks: This is the best solution yet, constant 60fps, no stuttering, but I can't change FOV which is a dealbreaker to me

Running RVGL on HyperV Ubuntu VM: works, but it goes around 30-40 fps, no stutters tho. Also no audio and can't make gpu acceleration work.


Troubleshooting things I haven't made:

Downgrading drivers: Just won't

Reinstalling Windows: Nope

Installing Ubuntu/Linux Mint: When I get a USB stick dedicated for this task

Possible causes:
Poor network connection: I have a VDSL connection around 30Mbps download and 5-10 upload, usually I'm not teleporting

Some random ass Windows service: highest possibility

Magik

Well, that's all for now, if anyone needs feedback or has a possible solution without renovating my PC I'd gladly help or take advice, but seems like I'll probably just play it on a linux flash drive :hansi:

(I can post clips but it's nothing fancy, I don't think it's necessary)
If you pay with yen I will give you discount...
User avatar
ZipperZbieracz
Posts: 307

Re: Constant stuttering in multiplayer

Unread post by ZipperZbieracz » Fri Oct 27, 2023 10:56 am

That's a "game freeze" issue, screen locks up for a short while and you continue driving afterwards from the place where you froze. Appears quite randomly, it's hard to pinpoint the issue (RVGL? CPU? RAM?). Lager (he uses a low-end machine) experiences/experienced it too. I actually had this issue appear in the past as well (on Linux Mint), but I haven't experienced this in at least a year or more, so this seems to have went away for me.
srett
Posts: 1

Re: Constant stuttering in multiplayer

Unread post by srett » Sun Dec 10, 2023 3:28 pm

Just registered to report the same issue. Last I played rvgl was in 2016 so looong ago, but the issue was not present back then.

We played on fairly ancient i5-3470 systems with the according iGPU (but then again the game should probably work on a potato by today's standards). I can also confirm that this only appears in multiplayer and scales with the number of players, an 8 player LAN-match lead to constant severe stutter and freezes of several seconds occasionally. It seemed the stutters were bound to certain locations in the maps, but that doesn't make too much sense to me given that there are absolutely no issues in singleplayer.

What's probably noteworthy here is that we played the 32bit Linux version, I guess not many people do nowadays, at least not on Linux.

When switching to wine + rvgl.exe, everything worked flawlessly, with 200+ fps most of the time if VSync was disabled, so an acceptable solution for our use case for now. Just wanted to give some feedback.
Last edited by srett on Sun Dec 10, 2023 3:29 pm, edited 1 time in total.
User avatar
Santiii727
Posts: 80
From: Maybe in your country

Re: Constant stuttering in multiplayer

Unread post by Santiii727 » Wed Mar 13, 2024 12:59 am

These stutters are more noticeable in the latest versions of RVGL, I don't know if they added something that affects it or it is a glitch of something accidentally activated from another operating system (such as some function of MacOS or Linux or Android or Windows) not corresponding to the one being used the game where it is installed. Idk but is my opinion.

Edit: Maybe it's the graphics card issues with this stutterings, at intel HD graphics not happens much and AMD idk, but can confirm with Nvidia happens every 1-2mins or 30 secs
User avatar
Sauss-Ente
Posts: 24
From: Behind the forest

Re: Constant stuttering in multiplayer

Unread post by Sauss-Ente » Wed Mar 13, 2024 10:09 pm

Playing on a Pentium D machine here from 2007. Even weaker is the Intel Atom from 2010 in a tiny netbook. So your computers have to be strong enough for RVGL.

Messing with the starting paramenters of RVGL improved the performance on the couple of laggy tracks (ex. Spa Volt, SBX Alpine).
On Linux, maybe try executing the game from the command line with those parameters:
./rvgl -nointro -noshader -profile -hidechat -cubevisi -nodemo
On Windows, open a command line in the RVGL folder and try it like this:
rvgl.exe -nointro -noshader -profile -hidechat -cubevisi -nodemo

These things clearly belong into the settings menus ingame, if they can have such a big impact on a game being smooth or laggy.

More options are in the documentation:
https://re-volt.gitlab.io/rvgl-docs/general.html
Post Reply