Problem with AI Nodes, any help appreciated (Fixed)

Report issues or bugs in RVGL or ask for help regarding any Re-Volt topic.
User avatar
Posts: 1

Re-Volt Problem with AI Nodes, any help appreciated (Fixed)

Unread post by FuzWooz » Tue Mar 26, 2024 1:15 pm

Hey there!

I'm fairly new to track creation and so far it's been a smooth sail, especially with the online documentation helping me, I've gone as far as completing the POS nodes, track zones, and now AI nodes too. But there's one issue I'm having with the AI nodes that I can't understand, I completed the racing and overtaking line themselves, but I can't change their properties? For example the 30mph slow down, turbo line, any of that stuff.

I originally was using the modern editor keybinds before switching to legacy, however on the documentation for the modern one I can't find any mentioned shortcut for this specific action after a long search. So I figured maybe there isn't one, so I switched to the legacy controls and for that it states Numpad Enter should do it, but for me Numpad Enter just behaves the same way as my regular Enter key, and just selects the node rather than altering any property. Another said Numpad Enter + Shift, however that doesn't do anything either. I've tried countless different keys with it and nothing has worked. I'm running on the latest RVGL version as of the time of this post (23.1030a1), and also have the -dev mode running.

Is there something I could be missing or not understanding? Any help would be greatly appreciated, thank you!

Edit: Nevermind I got it! Turns out my numpad enter key was actually just inputting the exact same function as regular enter, rather than being "numpad enter". I ended up remapping an extra key to specifically "numpad enter" and it worked.
Post Reply